Motorcycle Forum banner
21 - 26 of 26 Posts

Biker
Joined
1,756 Posts
O.K. Tyler do this, jump bike to GOOD car battery. remove wires from ignition switch and twist together, if you NOW have power it means. . .
1 you probably have an ignition switch with 3 terminals and you wired it wrong, take a closer look, usually there is letters next to the screws BAT, Ign. and maybe Lts for lights but if there are only two wires in harness by ignition sw. well you still might have hooked up wrong.

If nothing happens

2 There is a BAD fuse somewhere between Bat+ and wire to ignition sw. How many wires come off Bat+ either at battery or where heavy wire hooks to starter solenoid? has to be at least 2 but could be 3, 1 wire from ignition sw. 1 wire from R/R then to stator to charge battery. OR there could be a bad self re-setting breaker ( with a short circuit, it opens circuit same as shutting off current, cools down and closes circuit) if this goes bad, you get NO POWER this would look like a small box with screws on it. So with wires to ignition sw. twisted together and you see two or more wires hooked to a small box, that could be a circuit breaker. Damn dude don't you even bother to read OWNERS MANUAL? It will tell you these IMPORTANT things ! Ah balls man.
 

Biker
Joined
1,756 Posts
The headlight doesent come on the horn doesent make any sound the turn signals dont work it doesn't try to start or turn over ive checked all the fuses it acts like there no electric at all no lights come on no sounds from anything if I press the start button if i put it in neutral it will roll but it still won't start or light up if I try to. The manual doesent have a section for a problem like this ive already looked thru it probably 10 times.
Maybe they don't want you to work on the bike, any good bike builder would give you some tips on trouble-shooting.
 
21 - 26 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top