Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Im a motorcycle noob.

I have a Yamaha yzf 600 rt (c)

i noticed it first when i was going about 60 in 5th gear down a country road near my house. The tacho just dropped to zero and stayed for a few seconds, then jumped back to read what the motor was actually doing.

Now it does it in almost any gear past 2nd. but only temporarily each time

I dont really need to look at it anymore because ive gotten used to shifting on the bike.So I'm not sure if this is dangerous or not, just looking for some input on the matter.

Also, when shifting from 1st to 2nd, i have to double shift to avoid snatching "making a loud sound" when i hit 2nd. for example i have to half shift up to neutral then half shift up to second for a smooth shift. anytime i just try a full shift from first to second, i hear a loud clank and sometimes land in neutral regardless of how far up i pull the shift lever. Just wondering if this is a finesse thing that i just have to get used to or a common problem? Also is there a sweet spot in rpms where i should be shifting from 1st to second, and is it easier on the bike to pull in the clutch and shift before the tach drops at all, or ease into second by letting the tach fall a little while in mid shift?

sorry if my questions and info are poorly phrased.
 

·
Premium Member
Joined
·
5,274 Posts
Likely a loose wire in the tach circuit; could be power to the tach, or the signal pick off from the ignition. The wiring could also be rubbing and shorting on something, so check out the harness.

The shifting problem sound like the clutch isn't fully releasing. If the cable is adjusted properly, maybe you need an oil change?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3 (Edited)
Thanks for the reply

Ill take a look. It also wont start up sometimes, like its dead, but if i let it sit for a while or take the seat off and mess around with the battery and fuses, it will start right up. so im not sure if its the battery or a bad connection. i havent been able to start it on 4 different occasions now, and by not starting i mean no lights come on, no power at all to anything when i turn the key to the "on" position. but i still have yet to jump it off. so it dies but comes back to life by itself? not sure what the deal is. and ill change the oil and see if that helps with shifting, ill also get someone to help me adjust the clutch.

thank you again for the replies, they are very useful.

I almost forgot to mention! i was playing with my lights while my tach was acting weird and when id turn my brights on, the tach would raise about a half grand Ex. 5000rpm to 5500rpm. not sure if this means anything though.
 

·
Premium Member
Joined
·
5,274 Posts
You clearly have some electrical gremlins. Check all connectors for a tight fit; open them, make sure the contacts are clean, add a little dielectric grease, and mate them. If they feel like its a sloppy fit, the contacts may be going soft. Look for any damaged, scuffed, or pinched wires, and feel them for breaks. Just squeeze the suspect area between your fingers and bend the wires, and you should feel if there is a gap or crunch. Also, check the main battery cables; it is common for corrosion to creep down the cables and start breaking the strands. The cables should flex, with no extra stiffness at the ends than in the middle. Don't forget the engine/frame end of the big ground cable.
 

·
Registered
Joined
·
490 Posts
Definitely an electrical short causing the tach to fall to zero, and with the issues with starting, I'd begin looking at the battery.
Disconnect both terminals, get some fine sandpaper and 'shine' up the battery posts. If the posts are grungy and soiled, the sand paper will make them appear like you painted them with silver model paint. You might want to spend a buck or two at the hardware store on a couple of new bolts to connect to the battery (it'll be money well spent, if it saves ya from a long walk or late for work because the battery blinked out again). Some dielectric grease will help prevent the 'corrosion' from returning.
Don't really like diagnosing mechanical problems from afar, it's much better to see / hear the problem 1st hand.
 
1 - 6 of 6 Posts
Top