Motorcycle Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi,

I am a beginner rider. 250cc bike.
Yesterday I took the motorcycle for a short ride and after about 30km the engine stalled after trying to move from the stoplight. After three more attempts I finally managed to get it moving and attributed the problem to my clutch/throttle control (still have issues with uphill starts).

After another 10km same thing happened again, this time I noticed the engine temperature sensor going off. Waited 20 minutes for things too cool down and rode about 1km back home at turtle pace. Right next to my home I started to hear sounds resembling uncontrolled combustions like when you fuel a car with lower octane than required.

Upon further inspection there seem to be some coolant missing. Not sure how much yet (might have leaked a week before after a lowslide. There were a few drops on the ground after getting the bike up).


I am going to flush the remaining coolant, refill and of course check the radiator/pipes for any damage.

My question is, could there been any damage to the engine due to riding 40km with no coolant? Would it be safe to do coolant flush since I need to heat the engine for this? Should anything else be checked prior to do this?

Basically would appreciate any suggestions and ideas.
 

·
Gone
Joined
·
23,907 Posts
It's hard to say if the engine was damaged at this point. I would change out the coolant and give it a try. Make sure to check the oil level as well before attempting to start the engine.
 
1 - 3 of 3 Posts
Top