Motorcycle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey. I have a BMW RT 1100 (1996) and 2 problems:

Primo.

Previously I had a small incident on my motorbike. At the beginning all was fine. After a few hours my right indicator stopped working (front and back). I checked the cables near the bulb - isolation was burned and cables were touching each other. I separated and isolated them. It didn't help at all. This is probably not the fault of the indicator switch because when I turn on emergency light it switch only left side. In addition my right indicator switch, turn off the left switch.
I checked all 10 fuses and they are all fine. There are also some other boxes next to fuses, but I don't know what they are doing..

Should I put a whole new cable? Can this be relay?
Both, front and back indicators doesn't work.

Secundo.

This happened a week after my problems with indicators and may not have anything to do with them.
When I try to switch off the engine with my key, engine is still running. I can even take out the key and the engine still works.
I don't know whether it may have something to do with electronics, or rather with an ignition switch...?

:71baldboy:
 

·
Member Map
Joined
·
23,909 Posts
It could be the ignition switch or a short in the wiring. My guess is that the signals could be a blown flasher unit or yet another short.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
ok, engine switch has been fixed. I still can't fix indicator. Anyone had the same problem in the past?
 
1 - 4 of 4 Posts
Top