Motorcycle Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, Recently I lost my keys while camping and had to replace my ignition barrel, petrol tank lock and seat lock.
All went smoothly but now my indicators don't work.
Hazards or normal operation of the indicators - nothing.
Everything else works fine.
I thought I dislodged a connection so opened up the headlight and cleaned all the connectors with contact cleaner and checked they are all sitting correctly. Nothing
Checked the fuses and all are ok.
My bike is a Honda CBF 600N 2005
I have the Haynes manual which I've used to troubleshoot to no avail.
Any help would be greatly appreciated!! Cheers
 

·
Premium Member
Joined
·
5,984 Posts
I assume by 'indicators' you mean what we Yanks call 'turn signals'; right? The turn signal relay gets power on one wire, and is what controls the hazards and left/right through a selector switch or switches. Find that relay on your Haynes manual wiring diagram, and check for power when the key switch is on. I would set the run/stop switch to stop, so you don't cook the ignition. If power is there, follow the relay output to the selector switch(es). If no power, follow that wire back to the fuse. Also, check the diagram to see that the power does not come through the run/stop switch; stranger things have been designed.
 

·
Registered
Joined
·
1,682 Posts
Most likely turn relay gone if both sides and hazards quit. Nothing to do likely with the other issue of keys. Unless a wire got pulled loose in the work.
 

·
Premium Member
Joined
·
5,984 Posts
Yes, could be a coincidence that the turn relay failed when he replaced the rest. Maybe ...
 
1 - 4 of 4 Posts
Top