Motorcycle Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey everyone my name is Austin im 22 I live in Pennsylvania a little about myself I consider myself a jack of all trades Master of none especially being a mechanic lol I've been self teaching for the past 4 years on small engines mainly the little Chinese 125cc 4 strokes im currently stepping out of my safety zone i picked up a 2009 kawasaki ex650c off face book recently its become my winter project. I currently ride a 2018 ninja 650r ktr edition i own that and a knock off Honda grom that my wonderful girlfriend has been luring to ride on and the pervious mentioned 2009 ninja. I came here in search of some help for my newly acquired project. The issue i am having is i can get the bike to run I believe I traced it to a fuel delivery problem there 2 reaons I say that 1st off is when I picked the bike up it was sitting for about 5 years with gas left in it man did that ever stink lol. I started off with cleaning that up with some Vinegar the gas tank couldn't of came out better my next concern was the fuel pump thats thing was disgusting I cleaned it up as best as I could to find out it didn't work lol should of tested it before hand I found this out by hook up direct power to the positive and negative of it so I replaced the pump itself with an aftermarket one here's where I ran into my 1st problem when I disassembled the fule pump I didn't take note to any of the o ring placements especially the one I found tore to shareds in the fule pump im not able to find replacement ones or a diagram to show where they exactly were hopefully someone could help me out there the new pump came with o ring but definitely were the same as the ones I took off. The next reaon I believe fuel delivery is my problem i can spray some starter fluid into the air box and get her to pop off and if I continue to spray it the bike would run at very low rpms till I stop. Occasionally ill try to give it a start after its been sitting for a bit the bike would pop off again with no fluid but only last for a second and as soon as I go to give it gas shes dies out. Things I have tried. I put the fuel pump back together with no o rings the I tested to make sure it was working properly I disconnect the fuel line from the trottle body then tried starting it gas did come through the fule line so I believe everything from the fule pump to the line is soild except for I did read some where the fuel pressure should be btween 40 and 44 psi idk how to test that I dough the pressure is any where near that I was hoping that even if there was not enough pressure the bike would still run even if it was running crappy just to insure that was my only problem could it be im not getting enough pressure and thats why it's not starting? I also wanted to check the injectors to make sure they were good I could hear them clicking I could completely take them off but I hooked the fule line up to the put some gas in it and tried starting again I seen a light mist of gas comeing through i assumed that they were working correctly im not to familiar with them as im more use to a carburetor set up besides that theres nothing i can think of off the top of my head I tried doing if anyone can plz do thanks in advance.
 

·
MODERATOR
Joined
·
8,037 Posts
Welcome to a fantastic Forum! You have been approved to proceed and I'm sure you will receive lots of answers for your bikes problems!

Sam:)
64012
 

·
Visionary
Joined
·
4,082 Posts
Welcome and I'm in PA too. You might be on to something with the fuel pressure, did you buy the right kind of pump? Injected bikes use high pressure pumps ( usually 40-60 pounds), carburetor types use low pressure pumps. You need to make sure you have the right pressure..you can buy ( or maybe borrow) a fuel pressure tester from any decent auto parts store, I think that's what I would do next.
Now that your introduced maybe post this same question in a repair forum for more eyes on it.
 

·
Secret Agent
2006 Honda CBR1000RR, 2008 Honda CRF230L, 2019 Honda CRF1000L
Joined
·
1,869 Posts
Welcome from Kansas!
 

·
On The Road Again!
Joined
·
3,511 Posts
Welcome to the forum, Austin, from not-too-far-away New Jersey.
 

·
American Legion Rider
Joined
·
22,473 Posts
WELCOME ON BOARD, and...





We are friendly site here. Well, most of us





And thank you for giving us an introduction. We all appreciate it.
 

·
Retired twice: Navy and as a govt contractor
Joined
·
13,453 Posts
Welcome to the forum, I am a few miles south of you on the other side of Baltimore.
 
1 - 10 of 10 Posts
Top