Motorcycle Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
OK this is a bit of a saga so bear with me....
Bought a Yamaha xj600 ("diversion") like 6 weeks ago in Bishkek (had ~45,000 km on it), drove fine first 3 weeks at which point I circled back to a shop in Bishkek to put new brake pads and chain on it, also had the oil changed. The next morning it wouldn't start. Very strange timing so I checked the oil level and couldn't see the line (because was too high), so I drained some until the level was where it should be, but still no dice. A mechanic came over and thought it was an issue with the carb (mind you, language barrier in all my mechanic interactions here so I often have no idea what they're saying...), He recommended cleaning it. So I had it cleaned out and about 5 days and 1,000+ kms later it dies on me in the middle of nowhere (just gradually puttered off, would start up again a few times but for no more than 10 seconds before dying off again). Get a ride into Osh (Kyrgyzstan) , and a mechanic there diagnoses the problem as a faulty fuel pump. Ordered a new one online and switched them out. 2 days, ~600 kms later and the engine dies off while on the highway. With a couple 20ish minute breaks I get like 2 more 3 km stints out of it, at which point it won't start (maybe relevant, I'm now in Uzbekistan and had had to fill it with 80 octane petrol that day). Got a ride into Tashkent and looking for a mechanic, but starting to lose my faith in mechanics around here haha....
When I try to start it, the engine turns over but won't catch.
Any and all ideas would be much appreciated! Thank you!
 

·
Gone
Joined
·
23,907 Posts
I would check to see if the fuel tank is venting properly. If the fuel isn't being replaced by air as it is used, a vacuum will be formed in the tank, stopping the fuel flow.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks guys for the ideas!
Turns out I had low-ish compression in 2/4 cylinders, and replacing the piston rings should solve the issue.... I hope....
 
1 - 4 of 4 Posts
Top