Motorcycle Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey there, I have a 2019 Kawasaki w800 cafe
It has started to idle low and smells like gas. When I first start it cold it idles high for 3 seconds then fluctuates abruptly and as it get warm lowers and lowers- it just started doing this after I filled it up with gas- I tried adjusting the idle screw but it didn’t resolve the issue, any help would be appreciated. Thanks
 

·
Registered
CB125T, EX250 commuter, Ninja 250 racebike, CBR250R(MC19), VF500F, CBR600RR, VFR750F
Joined
·
603 Posts
Many things can be out-of-whack leading to rich fueling. Test and measure following according to steps in service-manual:

  • ECT & IAT sensors. Measure at ECU connector to also test wiring in between
  • fuel-pressure in fuel-rail. Might be failed FPR
  • O2-sensor, failed one will indicate full-lean to ECU, which will inject additional petrol to compensate

Since it started with fill-up, you may have gotten bunk tank of petrol. Dump it all out and refill from different station with octane-grade recommended by manufacturer.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Many things can be out-of-whack leading to rich fueling. Test and measure following according to steps in service-manual:

  • ECT & IAT sensors. Measure at ECU connector to also test wiring in between
  • fuel-pressure in fuel-rail. Might be failed FPR
  • O2-sensor, failed one will indicate full-lean to ECU, which will inject additional petrol to compensate

Since it started with fill-up, you may have gotten bunk tank of petrol. Dump it all out and refill from different station with octane-grade recommended by manufacturer.
Thaks for the reply Danno
I will start checking things, after doing some reading, I was thinking it was the EVAP system because I did spill a bit of fuel when filling it up with a gas can, I put the recommended octane from costco gas.
 

·
Registered
CB125T, EX250 commuter, Ninja 250 racebike, CBR250R(MC19), VF500F, CBR600RR, VFR750F
Joined
·
603 Posts
Spilling? Outside of bike? Should've stayed at refill station on ground.

Yes, EVAP canister can be damaged by too much liquid petrol. Don't overfill tank, up to little screen on inside only. Although there is separate vent-line for over-filling that should drain to ground.

If you have super-sniffer, you can try turning off bike after it starts smelling, then moving it into different area and try to sniff out source of leak?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Yes, outside of the bike left side I filled it with a gas can and the top was a bit loose. The tank was not overfilled though it was a little below recommended level. If it is the EVAP will it need to be replaced?
 

·
Registered
CB125T, EX250 commuter, Ninja 250 racebike, CBR250R(MC19), VF500F, CBR600RR, VFR750F
Joined
·
603 Posts
Usually you can disconnect canister and remove. Air it out couple days in hot sun and that should dry it out. Not likely EVAP because it's only vented back into engine once bike's warmed up and under some load (moving down road).

Too rich at warm-up has more to do with warm-up cycle in ECU. It might be getting erroneous data about actual outside temps. Amount of cold-start enrichment at 20F may be 2-3x more than at 70F.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
I see, I do want to check the o2 sensor. Maybe get someone to hook up a diagnostic tool to it, even though there are no check engine lights on. Thanks for the information. Have a good Thanksgiving, Danno
 

·
Visionary
Joined
·
6,215 Posts
Have you tried just getting rid of that gas and refilling it since the problem started after the fill up?
Sounds like it's running well enough to ride, easiest way to get rid of the gas is just take a nice 2 hour ride, 150 miles later fill up from someplace else and see what happens.
 

·
Registered
Joined
·
1,726 Posts
The idle behavior sounds normal.

On cold start a fuel injected engine will run the RPMs a little higher. Your engine should run at like 1300-1500rpm when you cold start it, then quickly comes down to like 500-1000rpm.

What RPM does it idle at when its warm?
 
1 - 10 of 10 Posts
Top