Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
186 Posts
Discussion Starter #1
Motorcycle would not start and headlight would not come on. Problem found. I recently repaired the kill switch and start button by bending back some copper contacts. Once I did that all good. Month later. I can still start bike and runsfine except headlight now tried to go on then fades away and finally no longer fires up. Bulb fine, only 12.OV low beam and mv high beam and ground good.

I knew I must replace wiring harness soon and just ordered one.

The contacts are pretty beat up and are from 2003.


So replacing harness when it comes in if that makes sense.

In past troubleshooting no shorts were found. Battery new, solenoid new, starter good, alternator good. Drives fine.
 

·
Registered
Joined
·
3,160 Posts
New connectors and drop testing

I am here to tell you that these connectors are great ! Just like OEM. http://vintageconnections.com/ I do not like their crimping tool. you can do a great job with some small tip bent pliers and a common flat wire crimper as a two part process

And to gain understanding in finding which ones are need replacing...http://www.motorcycleforum.com/showthread.php?t=151506. The author of the thread or myself will probably answer questions that you have about it.
 

·
Registered
Joined
·
186 Posts
Discussion Starter #3
Thanks

Awesome article and ref to tools, parts, etc:). As usual you are a great help. I hope other people check these references.
 

·
Registered
Joined
·
186 Posts
Discussion Starter #4
Slumlord

I just received my kill switch starter harness. Installed and headlight works fine now. Will rebuild old one for fun.

Plastic on rt handle that holds cable broke when installing. Ordered a new handle. Over the years disconnected a few times and probably old and broke. Cable are excellent condition. There are two. My handle is kinda worn anyways at 48k

Any easy way to get these cables on or loosen the tension?
 

·
Registered
Joined
·
186 Posts
Discussion Starter #7
Completed work

All finished. New starter button/kill switch harness and new throttle grip. I repaired some rusted clamps on my exhaust pipe shields and upon removing the pipes noticed there were no gaskets. Installed new ones.

Everything works.

There are some old rubber grommets I need to replace and I am ordering a new seat cover. Bike Bandit and Partszilla have been good places for parts. I figure there are many other good ones that have OEM.
 

·
Registered
Joined
·
3,160 Posts
Sorry that I missed you progress during the build.. Good job on figuring things out!
 

·
Registered
Joined
·
186 Posts
Discussion Starter #9
No problem. The only issue I had is I bought the larger o ring for both exhausts since one is slightly smaller than the other. That said, the copper o ring which is hollow inside was flexible and with slight pushing fit in there fine. See ya.
 
1 - 9 of 9 Posts
Top