Motorcycle Forum banner
21 - 22 of 22 Posts

·
Registered
Joined
·
5 Posts
The fact that the bulbs blew indicates the charging system is working. High voltage blowing the bulbs. The problem is more likely a battery that cannot except the rate of charge being fed it through the rectifier. Sulfation limits the amp hours the battery can except or put out, even though voltage may remain above 6 volts. Since the S90 has no regulator the battery acts as the regulator. Not being able to receive the voltage due to battery size, sulfation, age etc disrupts the voltage balance in the system. The old rectifiers do go bad and leak ac current also, since they aren't expensive to replace that may not be a bad idea along with a new properly sized 5.5hr battery.
Would you recommend anAGM 6v battery,or stick with a traditinal lead acid type with a vent tube ?
 

·
Registered
Joined
·
5 Posts
The fact that the bulbs blew indicates the charging system is working. High voltage blowing the bulbs. The problem is more likely a battery that cannot except the rate of charge being fed it through the rectifier. Sulfation limits the amp hours the battery can except or put out, even though voltage may remain above 6 volts. Since the S90 has no regulator the battery acts as the regulator. Not being able to receive the voltage due to battery size, sulfation, age etc disrupts the voltage balance in the system. The old rectifiers do go bad and leak ac current also, since they aren't expensive to replace that may not be a bad idea along with a new properly sized 5.5hr battery.
I changed out the rectifier and that sorted out the problem. Running fine now.
 
21 - 22 of 22 Posts
Top