Motorcycle Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
hi there i just joined up my name is mark howe im from new zealand currently residing in dunedin, and im needing help with my 1985 yamaha xz400 bike i got just recently if there is anyone that maybe able to help with my stalling problem i am having on my bike would be much appreciated thanks.
 

· Premium Member
Joined
·
11,108 Posts
Gidday Mark from a small Island in the Salish Sea. I have an 83 XS400 which I will assume is similar to your bike.
It is easy for the low speed jets to get plugged. A thorough cleaning of the carbs might fix your problem. Also replace the air filter if it has not been changed in a while.

UK
 

· Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
The thing that is happening I start my bike up from cold without choke give it bout a minute and the idle goes down to the point it where it just stalls and if I try to start up straight away it won't start if I wait a good 15 mins it will start up and it will repeat the steps all over again and if i open choke fully the bike will just stall instantly
 

· Save them all!
Joined
·
4,293 Posts
Hmm... have you checked for things that would make it run rich? Clogged air filter? Float level set too high? Float needle not seating?

Is the bike stock, or has it been modified?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top