Motorcycle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My bike still turns on and runs fine, but when i rewired my blinkers differently, it seemed like they started to short circuit when i was riding it after.
If i tried to flip on my right blinker it would just immediately cut off. Eventually, it cut off a lot of other things as well.
My lights, brights, and rear light still work and so does the speedometer light up.
However, my speedometer won't say my speed and the rpms doesn't show either (picture it as if the bike were sitting still). Also doesn't show my miles or bike temp. And when i brake the back light doesn't light up.

I know it has something to do with the new wiring but what exactly do i need to do to get all of it working again?
 

·
Member Map
Joined
·
23,909 Posts
Did everything work before the wiring was changed?

I would check for a short in the new wiring, then check for a blown fuse as a first step.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Did everything work before the wiring was changed?

I would check for a short in the new wiring, then check for a blown fuse as a first step.
Ya everything did work before I changed the wiring. The only thing I can recall as being a problem is that the left blinker was a little but duller with the original wiring. However after I rewired and the right one started to cut out, the left one started to shine way brighter than before. And I never rewired the left blinker. Just the right one
 

·
Retired twice: Navy and as a govt contractor
Joined
·
13,272 Posts
Also check your grounds
 
1 - 4 of 4 Posts
Top