Motorcycle Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, I have a 2006 Suzuki s40 Boulevard that I bought used a month ago. When I start the bike, it sounds fine but then starts to struggle after a few minutes when it's in idle position. Sometimes it will die. There's been a few times where I ride it and it everything seems fine until I slow down to 1st gear and it dies. Could this all be a carburetor problem? I have increased the idle RPM which helps when it's still but then when I ride it, it sounds really fast, like I'm revving the engine. The bike also has a loud backfire after I turn off the engine. That could be because the exhaust pipe is cut or its my carburetor. How much does it cost to get a carburetor cleaned in CA?
 

·
Ace Tuner
Joined
·
4,352 Posts
"Does my bike need the carburetor cleaned?"
The slow speed circuit in the carburetor (controls idle / slow RPM running) uses very small jets that 'plug-up' easily so I'd guess that yes, your bike probably needs the carburetor cleaned.


"The bike also has a loud backfire after I turn off the engine. That could be because the exhaust pipe is cut or its my carburetor."
Probably not anything to do with the exhaust pipe, sounds more like a carb problem.
 

·
Retired twice: Navy and as a govt contractor
Joined
·
15,917 Posts
You can try running something like Berryman, Gumout, Seefoam for a tank or two and see if that does anything. If not then yes you will have to clean the carb (s)
 
  • Like
Reactions: GatorJoe

·
Aging & Worn
Joined
·
4,544 Posts
My first bike, many years ago, tended to lag, like it was starving for fuel, when I would twist the throttle on entrance ramps onto highways, and such.

I bought a Service Manual, and methodically pulled the carbs and cleaned everything. After which, and at the recommendation of my trusty neighborhood Service guy, I bought and installed a thin ignition washer on the Main Jet, inside the Carbs. That allowed more fuel thru. It wasn’t the final fix, but it served as a temporary solution for a while.

Oh and, by the way......make SURE that you seat the carbs FULLY, when re-installing. It’s kinda a shocker if they let go!!! (lol)
 

·
On The Road Again!
Joined
·
4,649 Posts
I'd say run some Seafoam through it.
My Goldwing had been sitting for two years when I got it.
It did the same thing.
After a couple of cans of Seafoam, it runs great. No need to take anything apart.
 

·
Ace Tuner
Joined
·
4,352 Posts
After which, and at the recommendation of my trusty neighborhood Service guy, I bought and installed a thin ignition washer on the Main Jet, inside the Carbs. That allowed more fuel thru. It wasn’t the final fix, but it served as a temporary solution for a while.
Did you intend to say installed under the Jet Needle flange? ... Or am I missing something? :confused:

I'd say run some Seafoam through it.
My Goldwing had been sitting for two years when I got it.
It did the same thing.
After a couple of cans of Seafoam, it runs great. No need to take anything apart.
Wow. you guys must get some good pump gas up there.
The fuel we have down here (Houston) would be 'jelly' first then 'vanish' after two years. No way would it run without carburetor cleaning.
 

·
Swamp Rat Rider
Joined
·
1,928 Posts
You can try running something like Berryman, Gumout, Seefoam for a tank or two and see if that does anything. If not then yes you will have to clean the carb (s)

Best answer IMO .. Seafoam helped my 05 Dyna Garage Queen, would have cleaned the Carb as well as was not totally happy but knew would be rejetting the Carb Soon anyway as soon as upgraded the Cam Tensioners and Add Andrews Cams while at it .. Even after Seafoam, Carb was still dirtier than I expected but had mostly sat for 2 years when first bought it ..
 

·
Aging & Worn
Joined
·
4,544 Posts
Did you intend to say installed under the Jet Needle flange? ... Or am I missing something? :confused:


It’s been a number of years now, and I don’t typically do carburetor jobs, but it seem to me that the ignition washer was slid over the main jet needle and seated it itself against the base between the head of the needle valve and the place where the head of the main needle valve would’ve normally rested. I don’t remember there being any “flange.”

Like I said, that was a long time ago and I’m getting old now (lol)
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top