Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Dear friends
I own a 2017 BMW R1200 Gsa
today shortly after riding I noticed few things
the abs was flashing along with esa and service notification All at the same time. Than I noticed the speedometer would drop to zero even though I’m doing 60mph. I Accelerated few times while holding the clutch and speedometer would be instantly back to actual speed but other lights still flashing as I’m riding. I pulled over to maybe restart. Turned it off and tried to restart than noticed barely any juice to start and died and I haven't been able to even turn on the display aside from not starting the engine.
the bike has 12k miles and new battery just from 2months ago ..
I also checked the keyless battery It’s fine.
Any advice ? Thx
Alex
 

·
American Legion Rider
Joined
·
19,494 Posts
This sounds like a low voltage error problem. When the battery was changed 2 months ago, why? It might be your bike is not recharging the battery so you've been running off the stored power and during this last trip you ran the battery down completely. Or the new battery has an internal problem from the beginning so it wasn't getting recharged. Remove that new battery and have it tested to start with. Then based on whether it tests okay or not, either recharge it or replace it. In either case, then start testing your charging system. I don't have it in front of me but there is a post on the system somewhere that deals with how to check that part of your system. Or you can ask for further help later but you will need a voltmeter to correct your problem or take it to your dealership if that's the way you roll. Good luck though. I always hat seeing stranded motorcyclist.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thx for your kind efforts explaining.
i will definitely look into that .. when I purchased the bike 2months ago from dealer could not turn on the bike for me to test drive prior to purchase so they mentioned its been sitting and they just changed the battery for me. Who knows maybe they placed an old battery a guess. I’ll look into it shortly and share with you an update as well.
Blessings.
 

·
Registered
Joined
·
424 Posts
Your bike is probably still under warranty (36 months, 36000 miles). Make BMW fix it. But you should move quickly, you might be getting close to the 36 months.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thx Roger
Exactly what I did and since it was under warranty BMW has free roadside assistance for towing it turned out that the few wires loose on the battery not to mention the dealership I bought it from believe it or not had put the battery vice versa somehow and extended the cables but connected properly anyways fixed free of expense.
 
1 - 6 of 6 Posts
Top