Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
Ive got a 92 K75/S ABS and ive had the bike diagnosed at engle motors in KCMO the ABS light flashes even after the breaks of been cycled as mentioned in the owners manual. both ABS units are working properly, what i was told is what is causing the problem is the alternator even though its charging the battery to spec. the problem is the altinator needs a diode on one of its wires. this is what was passed down to engle motors from bmw. now they werent able to tell me what spec of diode is used. so is there anyone here that can tell me.
 

·
Banned
Joined
·
685 Posts
the problem is the altinator needs a diode on one of its wires. this is what was passed down to engle motors from bmw.
You need to get the details.....in writing....directly from BMW.
Or from someone who has done it successfully.
There might be a tech bulletin that covers it.

I find the story to be a little fishy; it may be lacking a critical detail or two.

I don't think that there are many BMW riders here; a brand specific forum might be more help.
 

·
Registered
Joined
·
10 Posts
My 1997 R-1150rt flashes long after the ABS check when the battery is low.

Yours may be different, but give it a big drink of charger and see if it stops.


Dan
 

·
Registered
Joined
·
182 Posts
Discussion Starter #4
well driver you are correct about the battery that applies to the k75 series and k100 series too.

ghost rider, they said at engle motors they have got a letter from BMW years ago about the issue, but had not had to service that issue in years. thats what i was told. $150 later just to diagnose the issue
 

·
Banned
Joined
·
685 Posts
ghost rider, they said at engle motors they have got a letter from BMW years ago about the issue, but had not had to service that issue in years. thats what i was told. $150 later just to diagnose the issue
If they can't give you the specifics about the problem AND the fix......then you got screwed. I don't trust anybody's memory from "years ago".

Let me take a wild guess at what the situation really was:
A diode in the rectifier failed so that the battery wasn't charging fully.
The fix was to find the bad diode and replace it.

Have you tried fully charging the battery yet ......and/or having it load tested......and testing the charging voltage ??
 

·
Registered
Joined
·
182 Posts
Discussion Starter #6
the bike starts and cranks no problem, the battery it has is the same one that came with it. and it charges the voltage stayes with in tolerance while charging and the charge holds.

whats going on. i fire up, the battery light stays on the abs light flashes and the check engine light comes on. with the abs on, cycle both brakes then the check engine light flashes with the abs and the battery light stays on. the battery is good and the abs is in working order ( i know i had to stand on the brakes on antioch tfwy in KCK and the brakes didnt lock) if its a diode needs that needs spliced in i just need to know what spec and i know where the electronic store is that has very much more then what radio shack carries.
 

·
Banned
Joined
·
685 Posts
whats going on. i fire up, the battery light stays on
That indicates a problem with the charging system.
What exactly do you mean by "stays within tolerance" ??

I get the feeling that you don't fully understand the importance of this but I will say it one more time: You need information directly from BMW and not from some shade-tree mechanic's fuzzy memory. It is a very rare case when tacking on extra parts is the proper fix for anything.

If the battery is the same one that "came with it" when it was new in 1992, then it is WAY past due for a change.....regardless of what the readings are.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #8
no no the battery is dated oct 2010. (lol ive the closest ive ever seen a battery lasting 20 years was a 7 year old 48V battery out of a cat dozer) Tolerance the voltage/amperes is not too high or to low while charging. and it holds enough voltage to cold start it around 30 degrees and it fires off less then 3sec at 60 and above.

never went to a shade tree mechanic i went to the 2nd dealership the bike has even lived. if anything im the shade tree mechanic.

i watch them test the battery at engle motors, they did everything best battery would have done.

engle motors is the only bmw dealer in kansascity ide have to go to st louis or denver to find the next one. the next best thing in kc that might know would be Harpers moto guzzi or reno power sports apirlia & ducatti

Best battery they have been around way longer then batteries plus and they are not a joke.
 

·
Banned
Joined
·
685 Posts
Tolerance the voltage/amperes is not too high or to low while charging.
I am asking you how you know that, exactly......but the bottom line IS that you need to squeeze your BMW dealer for details......or contact BMW yourself directly.

Were ALL of those lights lit when they had it last ??

You may need to have them look at it again; might be an intermittant problem that is getting worse.

Good luck. I'm out.
 
1 - 9 of 9 Posts
Top