Motorcycle Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So i ride with my dad 2 or 3 times a week this 1996 XV750H cc virago is immaculate and tediously kept in tip top shape... recently when riding for a few hrs at a time.. and he always rides lead and I follow so I'll be behind him and I'll be trying to maintain 55 mph so as not to pass him up I'll slightly let off the gas but try to keep it at a maintained position and it slightly cut out and loose power for a few seconds at a time... but doesn't die..has great power when accelerating or under a load just when trying to maintain anywhere from 45 to 55 mph in 5th gear... changed spark plugs, oil is good, air filter is clean an new.... carb is good just wanting to know what yall might think it could be?? also spark plug on the right side seems to be black after a ride... so dont know if thats related also idles great .. starts first push every time and doesn't smell like gas or oil.. please help just bonding with my dad over motorcycles and love to continue to ride and love the life style... thanks
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
cc rider... black dry.. yes after one ride carbs is good meaning clean adjusted right etc... just the right side plug.. they are gapped correctly according to the manual and are the right heat range ...will check the battery cables though. I'll let y'all know when I can thanks
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top