Motorcycle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
My 1981 Honda 750 Custom (with 15000 miles) just started to suddenly have a total electrical shutdown when idling. Engine quits, all lights go out and will not turn over. After turning the ignition switch and kill switch a few times everything is fine. After restarting runs great then all of a sudden total instant electrical failure again. Any help as to what to check would be appreciated. Thanks Larry
 

·
Member Map
Joined
·
23,911 Posts
Check the battery connections to make sure they are snug. Even a little loose can cause this problem.

Also be sure the battery is secured to the frame tightly so it can't move around and short itself out when the motorcycle is moving.
 

·
Registered
Joined
·
3,162 Posts
[ame]http://www.amazon.com/Emgo-Honda-Ignition-Switch-Repair/dp/B003CJCCKM[/ame]

Using the part number 35101-422-007 [OEM Honda] I found that the OEM is no longer available. While emglo is probably Chinese, you can use it with your original key cylinder and plug and play it to the existing electrical on your bike.

As previously posted,check your fuses/connections first. If you try to get an original Honda part,they will probably cost over 50 bucks and it is actually two separate part numbers--the contact base and also the switch cover

So the emglo switch at $8.44 shipped might be something to try. I have a Magna with the same symptoms as you have, and I think I will try this solution as I have already replaced the main fuse.
 
1 - 4 of 4 Posts
Top