Motorcycle Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
been working on this bike for a while now and have it running found out that Iam getting oil in the alternater cant see anything in the manual to tell me why havent takeing it apart yet any help would be greatly apreciated thanks Rob
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
what stops the oil from getting inside the magneto, the bike runs fine until oil gets inside than dosnt want to start i lose most of my spark it seems like thanks for the reply
 

·
Premium Member
Joined
·
5,649 Posts
There should be a pickup coil in the housing with the alternator, which triggers the ignition. It could be failing; since it is just a coil, it may have cracked insulation, and the oil shorts it out, or a flake of metal could be stuck to it. Normally, a small tooth or magnet passes by the coil, creating the trigger pulse, but it is a very small signal, so it doesn't take much to bleed it away. If the engine runs until warm, and then the spark goes bad, it is more likely the pickup coil has a broken wire in it, and the heat opens the crack; in that case, a new coil is required.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #5 ·
the eninge runs warm or cold but when the oil gets in it gives not enough spark to run will pull this out today also see what i find thanks
 

·
Premium Member
Joined
·
5,649 Posts
As Dods pointed out, oil is used to cool the alternator, so there is always some oil in there. Why would you think there is ever no oil there?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #7 ·
ok have that part figured out and bike running again thanks there nust be another problem after a few days or so it dosnt want to start if i clean this up clean oil off every thing than runs again
 

·
Premium Member
Joined
·
5,649 Posts
What part are you cleaning? Got a link to a photo?
Your post count is still kind of low, so you may have to type the link out, or give us a search string, to find a photo.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #9 ·
i cleaned the flywheel and the magneto just to remove oil and with a bit of emmery colth when this was done and put back together my spark was back not why yet but nows good starts 1st or 2nd kick every time might be looking in wrong place just have to wait till it happens again
 

·
Premium Member
Joined
·
5,649 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #11 ·
they have all been cleaned and checked all the way throu from alternater to spark plug all good thanks for wireing diagram
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #12 ·
still haveing problems with this if i clean alternator up clean oil off it will run for couple days than spark is low again and will not start something not right here pulling fly wheel tomorrow did find the wire from the big coil touching the little coil not sure about that yet maybe oil shorting wire out when wet
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #13 ·
still haveing problems with this, the bike on the side stand lets to much oil in I think not sure also this bike used to have lights it still has head light the rest where gone when i got it also thinking it used to have batt but cant find any where where it was plus no wireing for batt must have been removed thinking of trying batt elimantor this should give me spark at all times has any one tried this
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #14 ·
Bat-Pac BATTERY ELIMINATOR ~ Honda XL350 XL100 XL200 XL175 XL185 ~
Bat-Pac BATTERY ELIMINATOR ~ Honda XL350 XL100 XL200 XL175 XL185 ~
Item Id: 272045449590
End time: 13-Dec-15 22:44:33 EST
 

·
Premium Member
Joined
·
5,649 Posts
Assuming it is the same schematic for your bike, if you read the one at the link I posted, you will see that the battery is only to operate the lights, and the ignition only uses the magneto coil and a controller. Motor oil can become electrically conductive, so if there is any problem with damaged insulation on either the pickup coil wires or the magneto coil wires, spark can become intermittent when soaked in it. Since this would have to be the part of the wires inside the alternator/magneto housing, repair could be a problem, as it is hard to clean the wires well enough for any kind of coating to stick, and remain stuck with the heat involved. You may need to haunt eBay and used parts suppliers for replacements, or get really lucky with a NOS supply.

Just to add, the magneto coil for spark is grounded inside the housing, as is the coil that only powers the headlamp, and it could be that ground needs attention.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #16 ·
ok got that have been looking on ebay dont want to pay much didnt pay alot 4 the bike as for ground theres 4 screws didnt see anything else tried getting screws out with impact driver didnt move and didnt want to break case not sure of another way to get them lose
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #17 ·
the bike leans to left on kick stand so when oil in it drains to magneto the bike will run for about 3 days than will not start still have spark but not enough for ngk plug goneing to put in iridium plugs since this needs less spark to fire and goneing to keep bike up staited less oil in magneto
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #20 ·
I now have found out this bike has decompresion lever theres no cable on my bike so i cant tell where or how anything hooks up any help would be great thanks Rob
 
1 - 20 of 24 Posts
Top