Motorcycle Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
bike has 13k miles nice old bike all orignal. will a bad rotor stator make it run bad and cut out and not revv high . changed voltage regulator carbs are good. will a rotor stator bad not give the electric system enough power to make it fire right.. it has fire on num 3 but not hitting dead miss has good compression. it has spark but I think its weak... like the stator not putting out enough power to completely power the system thoroughly, I went and pulled the engine and topend just to find its perfectly fine looks great besides the center cam chain tensioner spring was broke and fell down in it so its not a complete mistake by taking it apart im going to put it back together just the way it was even the rings in the same spot they was in not honing it can still see the factory hone marks. anybody have anything think I should do to it while I have it apart . checked the valves everythings good on it no cracks or leaks
 

·
Registered
79 Cb750f
Joined
·
615 Posts
Charging is an issue on the 79 to 82s sometimes.
My 79, I put the headlight on a switch.
But the big issue was themolex plug at the end of the wires that come out of the right side of the motor. 1 was burnt. Couldn’t see it as they are kind of buried under the battery/fuse box and wires. It’s a one piece 4 connector
plug. I cut it out and put in 4 nice and clean individual plugs.
And yes, they get low on volts they run like ****.
 
1 - 2 of 2 Posts
Top