Motorcycle Forum banner

sputter

  1. Motorcycle Repair
    Hi guys, after trying to attempt to tackle this problem on my own I can't seem to get an idea where to start. The bike is a 79 gs850. My bike used to idle well before I encountered an electrical problem(If you read my last problem you'll know). This electrical problem required me to take the...
  2. Motorcycle Repair
    Howdy I have searched all over the internet for a solution to this problem, been to more than one mechanic and spent quite a bit with no success in solving this issue. As a result my cruiser has been parked for a few months now already. I'm from South Africa though and summer is here - need...
  3. Motorcycle Repair
    I bought a 2003 vstar 650 custom last spring. It was my first bike and I rode it every day. It ran fine up until the beginning of winter. The onset of the problem started slowly. I would be cruising at highway speeds (65-70) and suddenly, it lost half the power. Sounded as if only one cylinder...
  4. First Bike / New Rider
    My 1996 honda nighthawk is in great mechanical condition until recently, last night i took it for a ride and notcied something weird with the engine and throttle. if i were to start it up from a cold start, i would simply turn the choke on and start it, it would hover at a little above one, then...
  5. First Bike / New Rider
    As stated I'm new all around. I just got my first bike about a month and a half ago. I love it! It's a 2005 Suzuki GS500f. Like in the title though, I do have a problem though. A few weeks ago, I was riding home from work and the bike starts to sputter then stalls. I've only been riding about...
Top