Motorcycle Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Motorcycle Repair
    Hi everyone, Super weird one here, I installed new click in/removable indicators on my WR450f and they work perfectly when the ignition is on, without the motor running. As soon as I kick the motor over, they completely stop, and the voltage coming out of each indicator wire is -2v. Anyone had...
  2. Vintage Forum
    My bike was running normal before I changed out the speedo and tach bulbs. Not sure what I did but it is all messed up now. Neutral light is always on even when the key in off position and out. I can crank it over in all 3 ignition positions unless the headlight is plugged in. Turn signals do...
  3. Motorcycle Repair
    so my problem is that my bike wont start. well first off.. I have a 2007 Triumph Daytona 675. when i turn the key it goes though the little fuel cycle it does before starting. everything sounds fine and looks fine. when i hit the start button it just clicks and then goes back through the fuel...
  4. Motorcycle Repair
    My bike still turns on and runs fine, but when i rewired my blinkers differently, it seemed like they started to short circuit when i was riding it after. If i tried to flip on my right blinker it would just immediately cut off. Eventually, it cut off a lot of other things as well. My lights...
  5. Yamaha
    I tried to start bike (Yamama V Star XVS 650 Classic California model) but could not. Determined that there was no spark. Checked Ignition Coils. Rear coil howed a higher resistence than the range specified. I replaced, but still no spark. I cleaned connections and used grease for...
1-5 of 5 Results
Top