1985 honda shadow problem - Motorcycle Forum
Motorcycle Forum

Go Back   Motorcycle Forum > Manufacturers > Honda

Thread Tools
Old 09-10-2009, 07:37 AM   #1

Join Date: Sep 2009
Posts: 5
JunkHondaGuy is on a distinguished road
Default 1985 honda shadow problem

Hi, guys I apologize if this repeats but I tried to post once but can't find it.

I have a 1985 honda shadow vt700 which is mechanically sound but lately I'm having electrical issues. The blue 15a fuse in the front dash that controls the turns signals and brake light keeps on blowing, sometimes after a few minutes sometimes instantly, I'm no good at electrical issues and but am not sure where to start, the battery has a hard time keeping a full charge and if I can't start the bike on the first try I usually have to jump it, don't know if this matter but I've traced the current in the wires and it looks fine, but I obviously can't ride if I have no turns signals any help would be great.
JunkHondaGuy is offline   Reply With Quote

Advertisement [Remove Advertisement]
Old 09-10-2009, 08:23 AM   #2
Bald Headed Fat Man
Dodger's Avatar

Join Date: Jun 2009
Location: Virginia
Posts: 870
Dodger is on a distinguished road

You have a dead short somewhere in your wiring for the lights. Probably a wire got pinched and the insulation is off. Try checking continuity in each wire with a multimeter - sometimes they are tough to find.
Dodger is offline   Reply With Quote
Thread Tools

All times are GMT -4. The time now is 08:55 PM.

Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.