1979 Suzuki GS550 ignition issues - Motorcycle Forum
Motorcycle Forum

Go Back   Motorcycle Forum > Motorcycle Forums > Vintage Forum

Vintage Forum Classic and Vintage machines



Reply
 
Thread Tools
Old 09-05-2007, 11:18 PM   #1
Guy
COUNCIL MEMBER

Join Date: Sep 2007
Location: Colorado
Posts: 507
Guy is on a distinguished road
Question 1979 Suzuki GS550 ignition issues

I just picked up a 1979 GS550, and it has ignition problems. Carbs have been cleaned, new plugs, new points/condensers.

Someone told me the coils may be bad (makes sense), but they also said there may be an issue with the magneto. Not familiar with the magneto, is there a recommended method for testing it (let alone locating it)? I'm waiting for my Clymers to arrive, but I'd like to poke it until it shows up in my mailbox.

Thank you.
Guy is offline   Reply With Quote

Advertisement [Remove Advertisement]
Old 09-06-2007, 11:56 AM   #2
CB750F
Shantytown Mayor
 
CB750F's Avatar

Join Date: Jul 2006
Location: Huntingdon Co, PA
Posts: 4,722
CB750F is on a distinguished road
Default

Well, when you get your manual it will have in there how to test the coils and magneto with an ohm meter. I don't have the specifications or I would give them to ya. Sucks ya got to wait.
__________________
07 Ninja 500
98 ZX6E
CB750F is offline   Reply With Quote
Old 09-06-2007, 12:17 PM   #3
Guy
COUNCIL MEMBER

Join Date: Sep 2007
Location: Colorado
Posts: 507
Guy is on a distinguished road
Default

Well, it was worth a try anyway. At least I can go change the oil on all my bikes while I wait.

Guy
Guy is offline   Reply With Quote
Old 09-06-2007, 10:09 PM   #4
CB750F
Shantytown Mayor
 
CB750F's Avatar

Join Date: Jul 2006
Location: Huntingdon Co, PA
Posts: 4,722
CB750F is on a distinguished road
Default

Take your time

Who's the slowest person in the world? The mailman when you're waiting for something.
__________________
07 Ninja 500
98 ZX6E
CB750F is offline   Reply With Quote
Old 09-07-2007, 06:02 PM   #5
Guy
COUNCIL MEMBER

Join Date: Sep 2007
Location: Colorado
Posts: 507
Guy is on a distinguished road
Default

Well, both manuals arrived, so time to start reading. Oil was dirty in the 550, think I'll explore the carbs. I did get the starter circuit fixed -- corroded connection. I'll keep you informed, and thank you.
Guy is offline   Reply With Quote
Old 09-08-2007, 04:49 AM   #6
CB750F
Shantytown Mayor
 
CB750F's Avatar

Join Date: Jul 2006
Location: Huntingdon Co, PA
Posts: 4,722
CB750F is on a distinguished road
Default

Cool. Hey does your 550 have the gear position indicator? I had a GS 400 that had a digital readout for that but I'll be damned if I can remember if my 550 had it or not. I think it had some sort of gear indicator.
__________________
07 Ninja 500
98 ZX6E
CB750F is offline   Reply With Quote
Old 09-08-2007, 10:38 AM   #7
Guy
COUNCIL MEMBER

Join Date: Sep 2007
Location: Colorado
Posts: 507
Guy is on a distinguished road
Default

Yup, neutral light plus lights for gears 1-5, all along the bottom of the panel. Sorta handy for new riders, wish my wife could ride the 550, but it's too tall (or she's not tall enough). She just let me know she wants my Virago, grrr.
Guy is offline   Reply With Quote
Old 09-08-2007, 09:13 PM   #8
Guy
COUNCIL MEMBER

Join Date: Sep 2007
Location: Colorado
Posts: 507
Guy is on a distinguished road
Default

Normally I don't like putting different forum info in another forum, but this is not a direct competitor. I found a lot of good info specifically for the Suzuki GS series at http://www.thegsresources.com.
Guy is offline   Reply With Quote
Old 09-15-2007, 03:02 AM   #9
Guy
COUNCIL MEMBER

Join Date: Sep 2007
Location: Colorado
Posts: 507
Guy is on a distinguished road
Default

Update: Fixed the spark issues, still won't start. Putting in new battery cables (corrosion issues), new carb boot o-rings, new o-rings all over the carbs. Sigh... sure would like to get her going again...
Guy is offline   Reply With Quote
Old 09-06-2011, 05:29 PM   #10
maidenshredds
Motorcyclist

Join Date: Sep 2011
Posts: 7
maidenshredds is on a distinguished road
Default

i have a 79 GS550 as well, and my starts up fine, seems to idle okay, but at more or less half choke. is that normal? and when i rev it the rpms go up slow, but it blows blueish smoke and smells like 2 stroke exhaust like out of a weedwacker. im new to this, its my first bike.
maidenshredds is offline   Reply With Quote
Old 04-28-2014, 06:39 PM   #11
Blakrex
Registered

Join Date: Apr 2014
Posts: 1
Blakrex is on a distinguished road
Question

Quote:
Originally Posted by maidenshredds View Post
i have a 79 GS550 as well, and my starts up fine, seems to idle okay, but at more or less half choke. is that normal? and when i rev it the rpms go up slow, but it blows blueish smoke and smells like 2 stroke exhaust like out of a weedwacker. im new to this, its my first bike.

And two years later you probably already know it was a carb issue.
Blakrex is offline   Reply With Quote
Reply
Thread Tools


All times are GMT -4. The time now is 01:32 AM.

Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.