Sportster won't start - Motorcycle Forum
Motorcycle Forum

Go Back   Motorcycle Forum > Manufacturers > Harley Davidson and Buell



Reply
 
Thread Tools
Old 12-02-2010, 02:40 PM   #1
sunflashmace7
Senior Member

Join Date: Dec 2009
Location: Pensacola Fl
Posts: 496
sunflashmace7 is on a distinguished road
Default Sportster won't start

My bike must have heard all the compliments I have been giving it lately, because it just wont start today. My dad heard it making a clicking noise last night and he heard it again this morning I heard it as well when I turned on the bike before I hit the ignition switch into the on position didn't here it anymore so I thought ok lets try to start it. Bad Idea because the moment I hit the ignition switch it made a really loud Clack... CLACK. I cant really pin down where the noise is coming from any help would be appreciated.

I some trouble with it earlier this week I tried to start it warm and since I was in a hurry I had left the bike in first run into the house to get something and came back out and when I tried to start it all my lights went out. I drive this bike 5 days a week about 5 minutes to work so my first thought was battery. I charged it and everything seemed fine. Now I am thinking maybe a short somewhere? please help this is my main transportation and I need to be able to get to work without borrowing my wife's car.

a little self edit I have an 07 sportster 1200c that had the anti-theft removed because the previous owner had trouble with it.

quick update: I pulled the battery out and checked fuses didn't seem to be any bad fuses but the battery was down to about 2 volts which I am assuming would run the lights but not start possibly. I am getting really worried about maybe a ground out that is slowly draining my battery. I guess I am going to have to go over the wires at some point. heading to work please post with any advice or ideas about what may be causing this.

Last edited by sunflashmace7; 12-02-2010 at 03:14 PM..
sunflashmace7 is offline   Reply With Quote

Advertisement [Remove Advertisement]
Old 12-02-2010, 10:59 PM   #2
jvollmer
Senior Member

Join Date: Aug 2010
Location: South Dakota
Posts: 200
jvollmer is an unknown quantity at this point
Default

Is it charging? Check to see if it is charging.

Have the battery load tested after trickle charging it.

If those are both good you probably have something draining the battery. You can do a check for this as well. Let us know what you find.
jvollmer is offline   Reply With Quote
Old 12-03-2010, 10:17 AM   #3
Dodsfall
Administrator
 
Dodsfall's Avatar

Join Date: May 2008
Location: Illinois, USA
Posts: 19,295
Dodsfall is just really nice
Default

Have the battery load-tested. It could be shot. My stock battery only lasted two years.
__________________
2008 XL1200R

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dodsfall is online now   Reply With Quote
Old 12-03-2010, 11:19 AM   #4
gammaqueen
Senior Member
 
gammaqueen's Avatar

Join Date: Oct 2006
Location: North Carolina
Posts: 752
gammaqueen is on a distinguished road
Default

My stock battery on my Sportster didn't last long either.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ness Vision AKA Maj Tom & 1200XLL
gammaqueen is offline   Reply With Quote
Old 12-03-2010, 06:49 PM   #5
sunflashmace7
Senior Member

Join Date: Dec 2009
Location: Pensacola Fl
Posts: 496
sunflashmace7 is on a distinguished road
Default

I put the battery in it today and have run some errands. it seems to be ok I haven't heard the clicking noise that happened since it was off yesterday. I am still worried about something draining the battery so I am prolly gonna borrow the car for job #2 tonight and take a more in depth look at the wiring tomorrow when I have some free time.
sunflashmace7 is offline   Reply With Quote
Old 12-04-2010, 05:58 PM   #6
Lurch77
Veteran Member
 
Lurch77's Avatar

Join Date: Jan 2010
Location: Northeast Wisconsin
Posts: 1,777
Lurch77 will become famous soon enough
Default

The OEM battery in my 2006 Sporty is still good and strong. Battery Tenders are good.
Lurch77 is offline   Reply With Quote
Old 02-04-2012, 11:41 AM   #7
tj107us
Verified

Join Date: Jul 2011
Posts: 33
tj107us is on a distinguished road
Default

Yeah i have my battery go dead at a gas station, i just got off the interstate and was filling up my bike and i went to hit the sarter and nothing so i had to tailer it the rest of the way home because of harley's new safety thing where you cant roll it down a hill and start it.
tj107us is offline   Reply With Quote
Reply
Thread Tools


All times are GMT -4. The time now is 07:33 AM.

Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.