1980 xl 250 electrical issues - Motorcycle Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 08-07-2011, 05:20 PM Thread Starter
Motorcyclist
 
Join Date: Aug 2011
Location: Green bay Wi
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
1980 xl 250 electrical issues

I recently bought a 1980 honda xl 250s enduro and it has some electrical issues. The headlight and tail light work but the neutral light, high beam light and turn signals do not work. It has a new battery and all the wires are hooked up. So i dont know why they wouldnt work?
Any help would be great, thanks in advanced.
pj5454302 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-14-2012, 09:24 PM
Verified
 
PeteJC's Avatar
 
Join Date: Apr 2012
Location: Beebe, Arkansas
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Follow each wire to make sure you have good connections and no bare wires. You may need to disconnect clean and reconnect each wire as you go. Some electrical grease will help to assure your connections stay solid after you do your work.
PeteJC is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome